XSR 700 Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
Has anyone heard a wheezing /whistling sound of 2-3 seconds? Is seems like a warning of some kind (it's quite loud), and I've heard it after the first few metres of my ride (on two different days), as soon as I braked. There is no other warning or indication for a possible problem.
 

·
Registered
Joined
·
18 Posts
Is the ABS system supposed to give you a warning sign (sound) when it activates?
I feel mine kicking in every once in a while and I never heard anything.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #4 ·
As mentioned in the manual, it is supposed to give a clicking noise when it self-tests every once in a while.

What I hear does not sound "clicking" though.
 

·
Registered
Joined
·
20 Posts
sorry for the slow reply, yes dealer said new abs pump, just waiting for the part (still!).. due about now
 

·
Registered
Joined
·
46 Posts
Hi there, had the same problem since when I bought the bike (Feb 2019, it's from 2016, 20Kkms), and finally asked my dealer : the ABS pump is dying, probably due to oxydation.

They're contacting Yamaha for care.
 

·
Registered
Joined
·
20 Posts
very common, must be a faulty part. i will ask, if they ever actually get it, whether its an updated part.. failing that cheap enough on ebay i guess for those out of warranty.
 

·
Registered
Joined
·
46 Posts
Alright, I'm gonna have to bring the bike to my dealer (a 2h30 drive) for inspection and hopefully a quick fix under the dealer warranty. I'll keep this feed updated.
 

·
Registered
Joined
·
46 Posts
Update

Alright, defective ABS central unit confirmed, I'm lucky the bike was still under seller warranty for two weeks.

Hopefully it won't happen again.
 
1 - 13 of 13 Posts
Top