XSR 700 Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter #1
I have noticed that my seat has some free play and doesn't´t fits as steady as I would like.
The dealer told me that is normal.
Anyone has the same problem?
Any solution?
Thank you!
 

·
Registered
Joined
·
38 Posts
It's not normal, mine does not move. Your dealer is wrong.

Does the seat lock into place properly. Push down hard in the middle of the seat, you should hear it click into the lock position.

If there is a problem the dealer should fix it.
 

·
Registered
Joined
·
115 Posts
Sometimes I have to give my seat a good whack to get it to lock into place. Do you have the single or double seat?
 

·
Registered
Joined
·
85 Posts
Discussion Starter #4
I have the double stock seat, I hear the click when I place it but still has small free play.
You guys don´t have any free play? Its about half centimeter.
 

·
Registered
Joined
·
38 Posts
Mine has no free play and I have to push down quite hard to lock it into place.

Also there is no adjustment for seat looseness. The dealer may well be right in this case, if it's only a small amount of movement.

As long as the seat cannot be pulled off and is not moving around when you are sitting on it, I should not worry.

If it really annoys you, perhaps you could fit adhesive foam or rubber pads where the seat makes contact with the frame?
 

·
Registered
Joined
·
130 Posts
Half a cenitmeter (or even less, didn't measure it properly!) is also a movement that my seat has, you put it down, push it and hear the "click". It is locked and won't be removable or anything else, but it still will "dance" a bit for that kind of half centimeter movement.
That's how my bike does, I never thought about it as a problem, but maybe I was wrong :)
 

·
Super Moderator
Joined
·
622 Posts
I have the double stock seat, I hear the click when I place it but still has small free play.
Mine's exactly the same - wobbles from side to side about 5mm. A bit unusual but it's still securely attached and isn't going to fall off. No worries!
 

·
Registered
Joined
·
16 Posts
Hi there, mine does the same too! :( Had the feeling it was not normal. I originally thought it was my fault as once I didn't interlock the seat properly in the front rack. I had ride a hundred km like this without noticing it... But your comments tell me differently since few of you guys got the same slack... That doesn't sound good to me anyway, the stock seat should be completely sticked to the bike without any movement IMO
 

·
Registered
Joined
·
32 Posts
I have noticed the same thing, but I think it wasn't as bad when I got the bike... My guess is that it depends on how exactly you attach the latch which holds the seat in the front. Since you have to remove it to access the battery/fuse box etc I actually unscrewed this a couple of times. It is attached with four screws, but there is still some leeway to move it around... Might have something to do with it.
 
1 - 10 of 10 Posts
Top