XSR 700 Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1
Anyone had problem with rear brake light not working on foot pedal (okay on brake leaver) Been into dealer twice now and just discovered not working again. I will be dropping it back in again but just check to see if it's a common problem. Cheers
 

·
Registered
Joined
·
31 Posts
Have your really applied full pressure to the brake pedal as there is a lot of free play in the switch before it turns on. I know this because I adjusted mine to be more sensitive, breathe on pedal and light comes ON but light sometimes stayed on so had to put the free play back into the switch which means you have to brake quite hard to get light ON.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #3
Have your really applied full pressure to the brake pedal as there is a lot of free play in the switch before it turns on. I know this because I adjusted mine to be more sensitive, breathe on pedal and light comes ON but light sometimes stayed on so had to put the free play back into the switch which means you have to brake quite hard to get light ON.

Just double checked but no light even with hard pressure, I'll have a look to see if can adjust myself!!
 

·
Super Moderator
Joined
·
622 Posts
It's pretty easy to adjust the switch - I had to do mine after moving the brake pedal position. I've just moved an old thread on this issue into the 'tutorials' section.....it should help.
 

·
Registered
Joined
·
1 Posts
Hi, I’m new to this forum idk if anyone can help me since it’s a problem along the same lines as the stated above.

I bought a NRC fender eliminator for my XSR 700 2018. After installing it my turn signals work but my rear brake light wont come on. When I first installed it, it turned on but notice I had the turn signals lights swapped after switching them I introduced power again to check the lights but now the rear doesn’t even come on. Does anyone know a fix?
 

·
Registered
Joined
·
309 Posts
All we can recommend (without being there to see it in person) is to go back over EVERY step you performed when installing the fender eliminator. We assume all was well before that. And of course, check that rear brake light switch adjustment, and connector, maybe the spring came loose. The bracket for it may have been missed upon reassembly (if the rh foot peg was moved).
 

·
Registered
Joined
·
369 Posts
#1 rule when trouble shooting a problem. What did you do between working and not working. You'll find your problem there and when it's electrical it almost always is in a connector or switch, many times a wire mis-connected when it was put back together.
 

·
Registered
Joined
·
8 Posts
I have this exact problem did you find a fix?

Hi, I’m new to this forum idk if anyone can help me since it’s a problem along the same lines as the stated above.

I bought a NRC fender eliminator for my XSR 700 2018. After installing it my turn signals work but my rear brake light wont come on. When I first installed it, it turned on but notice I had the turn signals lights swapped after switching them I introduced power again to check the lights but now the rear doesn’t even come on. Does anyone know a fix?
 
1 - 11 of 11 Posts
Top