XSR 700 Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter #1
So I have had my bike since January and pretty quickly the two metal coolant pipes coming from the water pump have syrface corrosion caused by the insanely thin paint wearing away. It is such an exposed part I don't know why Yamaha didn't improve the coating.

I mentioned this to the dealer when booking my service and they are replacing the pipes under warranty.

So just a PSA if your pipes are similar it is worth speaking to the dealer. I'm going to ask for the old ones back so I can get them powder coated as I'm sure the new ones will eventually end up the same.
 

·
Registered
Joined
·
74 Posts
Crikey, I wouldn't expect that to happen so soon. I gave my bike a coating of Hybrid X so with a bit of luck I might get away with it. All the best dudes.
 

·
Registered
Joined
·
52 Posts
Discussion Starter #6
Had the pipes replaced with no issue. Bike looks new again so very happy. I couldn't keep the old ones as they needed to be sent back to Yamaha. Gave them a good coating of protection spray as soon as I got home so will just keep on top of it.
 

·
Registered
Joined
·
52 Posts
Discussion Starter #9
Just used acf50 on it. Not sure if there is anything better?

It is a painted metal part.
 

·
Registered
Joined
·
52 Posts
Discussion Starter #14
ACF50 has been ok for now but not really had bad/cold weather to ride in yet. If it happens again I think I will just get them powder coated.
 
1 - 14 of 14 Posts
Top