XSR 700 Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
Hi,
As above, I've now got the engine light on. It wasn't on before I cleaned it up for winter. The ABS light goes out when the bike is moved, just leaving the engine light on. The engine seems to be running ok, although I haven't ridden the bike, apart from on the driveway.
I can get a reader for £30 here in the UK to check out what the error code is.
I suspect there is some water somewhere in the electrics.
Do I need to get the reader, or maybe leave the bike a while? Or can it be cleared by disconnecting the battery for a while?
Many thanks,
Tony
 

·
Registered
2022 XSR 700, (Triumph Thunderbird 900)
Joined
·
16 Posts
Hi,
As above, I've now got the engine light on. It wasn't on before I cleaned it up for winter. The ABS light goes out when the bike is moved, just leaving the engine light on. The engine seems to be running ok, although I haven't ridden the bike, apart from on the driveway.
I can get a reader for £30 here in the UK to check out what the error code is.
I suspect there is some water somewhere in the electrics.
Do I need to get the reader, or maybe leave the bike a while? Or can it be cleared by disconnecting the battery for a while?
Many thanks,
Tony
On my old bike the engine light is a simple shortcut (wire) connected to the engine block. There is probably water lying there (I don’t know the location on the XSR) and when it dries the engine-light should go off again if water is the reason.
 
1 - 5 of 5 Posts
Top